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This entry originates from the Siemens Industry Online Support. The conditions of
use specified there apply (www.siemens.com/nutzungsbedingungen).

Security
Notes

Siemens offers products and solutions with industrial security functions which
support the secure operation of plants, solutions, machines, devices and/or
networks. They are important components in a comprehensive industrial security
concept. The Siemens products and solutions continue to be developed under
this aspect. Siemens recommends that you keep yourself regularly informed
about product updates.

For the safe operation of Siemens products and solutions it is necessary to take
appropriate security measures (cell protection concept, for example) and to
integrate each component in an overall industrial security concept which is state
of the art. This should also cover the third-party products used. Additional
information about industrial security is available at:
http://www.siemens.com/industrialsecurity.

In order to keep yourself informed about product updates, we recommend
subscribing to our product-specific newsletter. Additional information about this is
available at: http://support.automation.siemens.com.
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1 Introduction
This document guides you through the steps required to migrate a Mobile Panel
277F IWLAN project from SIMATIC STEP 7 to TIA Portal V11 and V12.

Contents
This FAQ response describes three ways of migrating/upgrading a Mobile Panel
277F V2 IWLAN project.
· Chapter 3: STEP 7 V5.5 → WinCC V11
· Chapter 4: STEP 7 V5.5 → WinCC V12
· Chapter 5: WinCC V11 → WinCC V12

Software requirements
The relevant software must be installed on your computer for each type of
migration or upgrade. The software requirements are provided in each chapter.

TIA Portal, WinCC and STEP 7
When "TIA Portal V11" or "TIA Portal V12" is mentioned in this document, we refer
respectively to "STEP 7 V11/V12" or "WinCC V11/V12" each in combination with
their safety components.
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2 Recurring Processes
The processes here occur in several of the migration scenarios described below.
Which steps you have to perform for which scenario is given in each chapter in the
"Requirements" section.

2.1 Transfer of Configuration Parameters

Note the following parameters before migrating from the configuration.
1. PROFIsafe address (F_Dest_Add)
2. PROFIsafe watchdog time (F_WD_Time)
3. PROFINET name (name of the Mobile Panel IO device).

Make sure that the name is DNS compliant (see DNS compliance of the
PROFINET device name, page 8)

4. PROFINET F input start address
5. PROFINET F output start address
The sections below show where to find the relevant parameters in your source
projects. The information is available at different points depending on the software
version. You must enter these parameters in the migrated project.
The instructions for this are in each section.
· Parameter transfer from a STEP 7 V5.5 project, page 5
· Parameter transfer from a TIA Portal V11 project, page 7
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Parameter transfer from a STEP 7 V5.5 project
Proceed as follows if your source project was created with STEP 7 V5.5.

Table 2-1

No. Action

1. In the SIMATIC Manager you open the Hardware Configuration of your plant and click the
Mobile Panel as PROFINET IO node.

2. In the table that opens you select the Slot 2 line with the fail-safe parameters.

3. Right-click to open the pop-up menu and select "Object Properties..." or double-click the table
line.

4. In the Properties dialog that opens you will find the relevant parameters in the tabs "General",
"Addresses" and "PROFIsafe".

1. PROFINET name

1
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No. Action

2.

1. PROFINET input start address
2. PROFINET output start address

3.

1. PROFIsafe address (F_Dest_Add)
2. PROFIsafe watchdog time (F_WD_Time)

1

2

2

1
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Parameter transfer from a TIA Portal V11 project
Proceed as follows if your source project was created with WinCC V11 (TIA Portal).

Table 2-2

No. Action

1. In the TIA Portal V11 you open the "Device overview" of the GSDML module.
2. Open the table area of the Device overview and select the line with Slot 2.

The name entered under "Module" is also the name of the Mobile Panel IO device
(PROFINET name).

3. In the Inspector you open the "Properties" tab.
4. In the area navigation you select "PROFIsafe" and "I/O addresses" to see the other

parameters.

1. PROFIsafe address (F_Dest_Add)
2. PROFIsafe watchdog time (F_WD_Time)

1

2
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No. Action

3.

1. PROFINET input start address
2. PROFINET output start address

DNS compliance of the PROFINET device name
The following requirements must be fulfilled for the device name to be DNS
compliant.
· Limit of a total of 255 characters (letters, numbers, hyphens and periods).
· The name must begin with a letter.
· The name must end with a letter or number.
· A name component of the device name, a character string between two

periods, for example, must not be longer than 63 characters.
· No special characters like umlauts, parentheses, underscore, slash, space etc.

are permitted.

2.2 Installation of the Version-dependent F Blocks (F-FBs)

To ensure successful migration, the FFBs for the Mobile Panel 277F IWLAN for the
Safety option of STEP 7 Professional V11 or V12 must be installed.
The FFBs are available for downloading in the Siemens Industry Online Support
Portal. (see Chapter 6)

Table 2-3

No. Action

1. Download the FFBs from Entry ID 45787660 in the Siemens Industry Online Support Portal.
Make sure you select the correct library (V11 or V12) for your migration task.

2. Unpack the ZIP archive in a directory of your choice.
3. Run the Setup of the installation file.

You can only call the F blocks via the global library in the WinCC (TIA Portal).

1

2

http://support.automation.siemens.com/WW/view/en/45787660
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2.3 Update of the STEP 7 Hardware Catalog

Make sure your STEP 7 hardware catalog is up to date before starting the
migration.

Table 2-4

No. Action

1. In the SIMATIC Manager you open the hardware configuration and select "Options > Install
HW Updates..." from the menu.

The "Install Hardware Updates" dialog opens.
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No. Action

2. Enable the "Download from Internet" option or the "Copy from disk" option depending on the
source you want to use for the update.

Click "Execute...".
3. The hardware catalog files are downloaded. This can take several minutes depending on the

internet connection.

4. Click "Select All" to update all the components.
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No. Action

5. Click "Install".

6. Answer the confirmation prompt by clicking "Yes".

Also click "Yes" to confirm the prompt with which all the STEP 7 applications are closed.
7. The catalog updates will now be installed. This procedure can take several minutes.

8. Reboot the SIMATIC Manager after installation has been completed.
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2.4 Password Querying of the Safety Configuration

At several points of the migration you will be prompted to enter the password for
the safety program.
Table 2-5

Dialog for password input, STEP 7 V5.5

Dialog for password input, TIA Portal V11

· When the dialog opens, you enter the password and confirm with "OK".
This step will not be executed each time in the following table.
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3 STEP 7 V5.5 → WinCC V11
This chapter explains how to migrate a project with a Mobile Panel 277F IWLAN
from SIMATIC STEP 7 V5.5 to WinCC V11.

3.1 Requirements

Software configuration
The following software configuration must be installed for the migration procedure.
· For the source project:

– STEP 7 V5.5 + SP3
– S7 Distributed Safety V5.4 + SP5
– WinCC flexible 2008 SP3

· For the target project:
– STEP 7 Professional V11 SP2 Update 5
– STEP 7 Safety Advanced V11
– WinCC Advanced V11 SP2 Update 5

Error-free source project
The current project was generated error free in STEP 7 V5.5 and WinCC flexible
2008.

Noting the F parameters of the configuration
You have noted the F parameters of the STEP 7 configuration, see Transfer of
Configuration Parameters, page 4 .

Installed F blocks
The F blocks for TIA Portal V11 are installed.
See Installation of the Version-dependent F Blocks (F-FBs), page 8 for the
procedure.

Updating the hardware catalog in STEP 7
The hardware catalog has been updated according to Update of the STEP 7
Hardware Catalog, page 9.

3.2 Migration of the Project

Installation of the Hardware Support Packages (HSP) for WinCC (TIA Portal) and of the
GSDML file for the Mobile Panel 277F IWLAN V2

The GSDML file for the Mobile Panel 277F IWLAN V2 must be installed for the
migration procedure. This and the GSDML file for the Mobile Panel 277F IWLAN
(RFID Tag) are part of the Hardware Support Package which you can download
from the Siemens Industry Online Support Portal. (\2\)
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Table 3-1

No. Action

1. Download the HSP for WinCC (TIA Portal) from Entry ID 60497002 in the Siemens Industry
Online Portal.

2. Unpack the ZIP archive in a directory of your choice.
3. Open the Project view in WinCC (TIA Portal).
4. Select the menu command "Options > Install general station description file (GSD)".

5. A dialog box opens.

Under "Source path:" you select the directory in which you have stored the GSDML file.
6. Select the GSDML file "gsdml-v2.2-siemens-hmiiwlanv2-20100809.xml" and then click

"Install".

http://support.automation.siemens.com/WW/view/en/60497002
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Migrate STEP 7 project to WinCC V11
Table 3-2

No. Action

1. In the Start portal of WinCC (TIA Portal) you select the "Migrate project" action.

2. Choose the STEP 7 project to be migrated.
3. Disable the "Exclude hardware configuration" option.
4. Specify a project name and target path for the new project.
5. Then click "Migrate".

Rebuild the project
Table 3-3

No. Action

1. Mark the PLC and in the pop-up menu you select the function "Compile > Software (rebuild all
blocks)".
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No. Action

2. After rebuilding you get an error message saying that F blocks you used in your project (in our
example "F_FB_MP" and "F_FB_RNG_4") could not be created.

Now you must replace the relevant FFBs from the STEP 7 V5.5 project with the FFBs for
WinCC V11  (see Table 3-4).

Replace FFBs
Table 3-4

No. Action

1. Open the "Libraries" task card.
2. There you open the "Global libraries" palette and navigate to the folder with the F blocks for

the Mobile Panel.
3. Replace the blocks which caused the compilation error (in our example: "F_FB_RNG_4" and

"F_FB_MP") by dragging and dropping the blocks from the global library to the project
navigation.

4. When you insert an F block, you get the following message.
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No. Action
Use the option "Replace existing objects and move to this location".

5. Repeat these steps for the other F blocks for the Mobile Panel you are using in your project.
6. When you have finished replacing the FFBs, mark the PLC and in the pop-up menu you select

and run the function "Compile > Software (rebuild all blocks)".

GSD file – change version
Table 3-5

No. Action

1. In the Project tree you open the Device configuration and there you select "Network view".
In the Network view you will find the GSD module for the Mobile Panel displayed among other
things. You must replace this with the GSDML module for WinCC V11.

2. Mark the GSDML module of the Mobile Panel and open the "Properties" tab in the inspector. In
the area navigation you select "Catalog information".

3. Here you click the "Change revision" button.
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No. Action

4. The "GSD file - change revision" window opens.
Here you select the GSD file "gsdml-v2.2-siemens-hmiiwlanv2-20100809.xml".
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No. Action

5. Now you can also select one of the options offered. In this example we have chosen "All
matching IO devices of the current project".

6. Confirm the selection with "OK".
7. To update the change in the Device configuration, close the Device configuration window and

open it again.
8. The figure below shows the new view of the changed GSDML module.
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Change the F parameters
Now transfer the F parameters of the SIMATIC STEP 7 configuration you noted
previously (see Transfer of Configuration Parameters, page 4) into the
TIA Portal V11 project.

Table 3-6

No. Action

1. Open the Device view of the GSDML file of the Mobile Panel.

2. Open the table area of the Device overview.
3. Mark the module in Slot 2 (in our example: "Mobile277failsafe_IO").
4. In the inspector window you select the "Properties" tab.
5. In the area navigation you select "PROFIsafe".
6.

Enable the "Manual setting of F_WD_Time" option.

1

2



3 STEP 7 V5.5 → WinCC V11

Migration MP277F IWLAN in TIA-Portal
Entry ID: 75201316,    V1.0,    05/2014 21

C
op

yr
ig

ht
ã

S
ie

m
en

s
A

G
C

op
yr

ig
ht

-2
01

4
A

ll
rig

ht
s

re
se

rv
ed

No. Action

7. Enter the noted values for "F_Dest_Add" and "F_WD_Time" in the relevant fields (1) and (2)
respectively.

8. In the area navigation you select "General".
9.

Enter the device name in the "Name" field (3).

Behavior in the case of checksum errors
Proceed as follows if you get a checksum error during compilation of the HMI
configuration in the TIA Portal V11.

Table 3-7

No. Action

1. Start a device replacement by going to the Device overview of the panel, right-click the device
to open the pop-up menu and select the "Change device" command.

3
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No. Action

2. Replace the Mobile Panel 277F IWLAN V2.0 with the non-fail-safe
Mobile Panel 277 IWLAN V2.0.

3. In the Project tree you mark the Mobile Panel and in the pop-up menu you select the
command "Compile > Software (rebuild all)".
After compilation you get a list of errors which you can ignore for the time being.

4. Undo the device replacement by going to the Device overview of the panel, right-click the
device to open the pop-up menu and select the "Change device" command.
Replace the Mobile Panel 277 IWLAN V2.0 with the fail-safe Mobile Panel 277F IWLAN V2.0.
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No. Action

5. Switch to the Network view.
6. Click the Connections button to enable Connection mode.
7. Establish a connection between the Mobile Panel and the CPU by clicking the interface of the

Mobile Panel (1). Keep the mouse button pressed and drag the mouse to the PROFINET
interface of the CPU (2). Release the mouse button.

8. Mark the panel in the Network view and open the table area of the Network view.
9. Select the "Connections" tab and mark the first local connection shown.
10. In the inspector window you open the "Properties" tab and select "General" in the area

navigation.
11. In the "Interface" drop-down list box you select the "IE_CP_1, PROFINET_Interface…" item.

1 2
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No. Action

12. In the Network view table you select the second local connection and in the inspector window
you likewise select the interface "IE_CP_1, PROFINET_Interface…".

13. Switch to the Device view of the Mobile Panel.
14. In the inspector window you open the "Properties" tab and select "PROFINET interface (X1)"

in the area navigation.
15. Under "IP address" and "Subnet mask" you enter the IP parameters of your panel.

The configuration can now be compiled without errors.
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Compile and download the configurations (hardware and software)
Table 3-8

No. Action

1. In the Project tree you mark your CPU and right-click to open the pop-up menu.
2. Select the "Compile > Hardware configuration" command.

3. Then select the "Compile > Software (rebuild all blocks)" command.
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No. Action

4. Next you select the  "Download to device > Hardware configuration" command.

5. Then you select the  "Download to device > Software (all blocks)" command.

6. In the Project tree you mark your Mobile Panel and right-click to open the pop-up menu.
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No. Action

7. Select the "Compile > Hardware configuration" command.

8. Then select the "Compile > Software (rebuild all)" command.
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No. Action

9. Then you select the  "Download to device > Software (all)" command.

This completes the migration procedure.
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4 STEP 7 V5.5 → WinCC V12
This chapter explains how to migrate a Mobile Panel 277F IWLAN from SIMATIC
STEP 7 V5.5 to WinCC V12.

4.1 Requirements

Software configuration
The following software configuration must be installed for the migration procedure.
· For the source project:

– STEP 7 V5.5 + SP3
– S7 Distributed Safety V5.4 + SP5
– WinCC flexible 2008 SP3

· For the target project:
– STEP 7 Professional V12 SP1 Update 3
– STEP 7 Safety Advanced V12
– WinCC Advanced V12 SP1 Update 3

General requirements
The project is compiled as an executable STEP 7 V5.5 project.

Noting the F parameters of the configuration
You have noted the F parameters of the STEP 7 configuration, see Transfer of
Configuration Parameters, page 4 .

Installed F blocks
The F blocks for TIA Portal V12 are installed.
See Installation of the Version-dependent F Blocks (F-FBs), page 8 for the
procedure.

Updating the hardware catalog in STEP 7
The hardware catalog has been updated according to Update of the STEP 7
Hardware Catalog, page 9.
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4.2 Migration of the Project

Update the version of the GSD file in STEP 7 V5.5
This step is necessary only if the GSD file of your STEP 7 project is currently not
up to date.

Table 4-1

No. Action

1. In the HW Config you mark the icon of your GSDML module, right-click to open the pop-up
menu and select "Properties".

Click "Change Release Number...".
2. In the "GSD File - Change Release Number" dialog that opens you select release "8/9/2010"

from the GSD files shown.

Press "OK".
3. Also confirm the Properties dialog with "OK". Then recompile the project.

This brings the revision of the GSD file up to date.
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Project migration
Table 4-2

No. Action

1. Open the TIA Portal V12.
2. In the Portal view you select the "Migrate project" command and navigate to your STEP 7

project.

3. Enable the "Include hardware configuration" option.
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No. Action

4. Click "Migrate".

5. The migration is carried out.

6. The migration terminates with a number of warnings which you can ignore for the time
being.

7. Now it is imperative that you close the migrated project and then open it again!

Create new connections
Table 4-3

No. Action

1. Open the Network view of your project.
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No. Action

2. Click the Connections button to enable Connection mode.
3. Create a connection between the CPU and the Mobile Panel by clicking the PROFINET

interface of the CPU, keeping the mouse button pressed and dragging a connection to the
interface of the Mobile Panel.

Activate the panel
Table 4-4

No. Action

1. Mark the Mobile Panel and open its Device view in the TIA Portal.
2. In the area navigation of the inspector window you select "Operating mode".
3. Enable the "IO device" option to activate the panel as PROFIsafe device.

4. In the "Assigned IO controller:" drop-down list box you select the controller to which the panel
is to be connected and confirm your selection.

5. Save your project.

Change the F parameters
Enter the F parameters of your STEP 7 project, which you noted under Transfer of
Configuration Parameters, page 4, in the TIA Portal V12 project.

Table 4-5

No. Action

1. In the TIA Portal V12 you open the Device view of the Mobile Panel.
2. In the table area of the Device view you select the line "WinCC flexible RT".
3. In the inspector window you open the "Properties" tab and select "F-parameter" in the area

navigation.
4. Enable the option "Manual assignment of F-monitoring time".
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No. Action

5. Transfer the following parameters from your STEP 7 V5.5 configuration into the TIA Portal
V12:
(1) The PROFIsafe watchdog time "F_WD_Time" to "F-monitoring time"
(2) The PROFIsafe address "F_Dest_Add" to "F-destination address"

6. In the area navigation you switch to "I-device communication".
7. Transfer the following parameters from your STEP 7 V5.5 configuration into the TIA Portal

V12:
(1) PROFINET input start address to "Transfer areas > IO failsafe"
(2) PROFINET output start address to "Transfer areas > IO failsafe"

8. In the Project tree you select your CPU.

1

2

1

2
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No. Action

9. From the pop-up menu you select "Compile > Hardware (only changes)".

10. From the pop-up menu you select "Compile > Software (rebuild all blocks)".

11. Save your project.
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4.3 Finalizing

Update the FFBs
When compiling the CPU configuration, you might get the error message indicating
that various FFBs need a valid password to be compiled.
Figure 4-1

These F blocks used in your project must be replaced by TIA Portal V12 F blocks.

Table 4-6

No. Action

1. Open the "Libraries" task card.
2. Open the "Global libraries" palette.
3. Navigate to the library path "Failsafe HMI Mobile Panels > Master copies > MP277F_IWLAN >

S7-300/400 > V1.0".
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No. Action

4. Replace the blocks which caused the compilation error (in our example: "F_FB_RNG_4" and
"F_FB_MP") by dragging and dropping the blocks from the global library to the project
navigation.

In doing this you overwrite the old version of the blocks.
5. When you insert an F block, you get the following message.

Enable the option "Replace existing objects and move to this location" and confirm by clicking
"OK".

Delete old F instance DBs
When compiling the CPU configuration, you might get the error message indicating
that various instance DBs (connected to FFBs) cannot be compiled.
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Figure 4-2

Proceed as follows to delete the faulty blocks.
Table 4-7

No. Action

1. In the Project tree you open the folder of your CPU (here: "CPU 319F-3 PN/DP") and there
you open the subfolder "Program blocks".

2. Mark the instance DBs which caused the compilation errors, right-click to open the pop-up
menu and select the "Delete" command.

The blocks will automatically be rebuilt correctly during the next compilation
procedure.
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Update the F DBs
When compiling the CPU configuration you might get the error message indicating
that several tags like "QBAD", "ACK_REQ" or "ACK_REI" of a configured DB are
not defined. The DB that caused the error (in our example:
"F00256_Mobile277failsafe") is the "F IO DB" defined in the F parameters of the
panel.

Figure 4-3

Table 4-8

No. Action

1. Open the Device view of the Mobile Panel.
2. In the table area of the Device view you select the line "WinCC flexible RT".
3. In the inspector window you open the "Properties" tab and in the area navigation you select

the "General" tab and then the "F-parameter" item.
4. Under "F-IO DB-name" you will find the correct name of the data block.
5. In the Project tree you open the folder of your CPU and the subfolder "Program blocks >

System blocks > STEP 7 Safety >F-IO data blocks".
6. Select the data block located there and right-click to open the pop-up menu.
7. Select the "Rename" command and assign the block the name entered under "F-IO DB-

name".
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Compile and download the configurations (hardware and software)
Table 4-9

No. Action

8. In the Project tree you mark your CPU and right-click to open the pop-up menu.
9. Select the "Compile > Hardware (only changes)" command.

10. Then select the "Compile > Software (rebuild all blocks)" command.
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No. Action

11. Next you select the "Download to device > Hardware configuration" command.

12. Then you select the "Download to device > Software (changes only)" command.

13. In the Project tree you mark your Mobile Panel and right-click to open the pop-up menu.
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No. Action

14. Select the "Compile > Hardware (only changes)" command.

15. Then select the "Compile > Software (rebuild all)" command.
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No. Action

16. Then you select the  "Download to device > Software (all)" command.

This completes the migration procedure.
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5 WinCC V11 → WinCC V12
This chapter explains how to upgrade a Mobile Panel 277F IWLAN project from
WinCC V11 to WinCC V12.

5.1 Requirements

Software configuration
The following software configuration must be installed for the upgrade procedure.
· For the target project:

– STEP 7 Professional V12 SP1 Update 3
– STEP 7 Safety Advanced V12 Update 1
– WinCC Advanced V12 SP1 Update 3

It is not necessary to have STEP 7 V11 or WinCC V11 installed.

General requirements
The project is compiled as an executable TIA Portal V11 project.

Noting the F parameters of the configuration
You have noted the F parameters of the TIA Portal V11 configuration, see Transfer
of Configuration Parameters, page 4 .

Installed F blocks
The F blocks for TIA Portal V12 are installed.
See Installation of the Version-dependent F Blocks (F-FBs), page 8 for the
procedure.
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5.2 Upgrade of the Project

In the procedure we describe here, both the TIA project and the configuration of
the panel will be upgraded to version V12.

Open and upgrade the project
Table 5-1

No. Action

1. Open the TIA Portal V12 use it to download the project you created with version V11.

Note: Do not use the menu command "Migrate project".
2. Select the "Project" tab and then the "Upgrade" command.

After conversion the TIA Portal automatically opens the upgraded version of your project.
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No. Action

3. You get a message indicating that to complete the conversion you must recompile the
project.

4. Acknowledge the message with "OK", but only run the compilation after you have performed
the following configuration steps.

Change the Mobile Panel
Table 5-2

No. Action

1. Open the Device overview of the Mobile Panel and in the inspector window you select the
"Properties" tab and in the area navigation you select "General".

2. Click the "Change device/version" button.
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No. Action

3. In the hardware catalog, under "New device" you open the directory "HMI > SIMATIC Mobile
Panel > 270s Series".

4. Click "Mobile Panel 277F 8‘‘ IWLAN V2".
Make sure that the number "12.0.0.0" is displayed for "Version".

5. Confirm by clicking the "OK" button.

Activate panel
Table 5-3

No. Action

1. Open the Device view of the Mobile Panel.
2. In the inspector window you open the "Properties" tab and in the area navigation you select

the "General" tab and then the "Operating mode" item.
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No. Action

3. Enable the "IO device" option.

4. In the "Assigned IO controller:" drop-down list box you select the CPU to which the panel is
to be connected (in our example: "CPU 319F-3 PN/DP.PN-IO") and confirm your selection.

5. Now save your project.

Delete the GSDML module
Table 5-4

No. Action

1. In the Network view you mark the GSDML module.

2. Right-click to open the pop-up menu and select the "Delete" command.

Finalizing
Now perform the steps in section 4.3, Finalizing.

This completes the migration procedure.
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6 Links to the Siemens Industry Online
Support Portal

Table 6-1

Topic Address

1. Where can you download the F
FBs for the Mobile Panel 277F
IWLAN for the Safety option of
STEP 7 V5.5, STEP 7
Professional V11 and STEP 7
Professional V12?

http://support.automation.siemens.com/WW/view/en/45787660

2. Hardware Support Packages
(HSP) for WinCC (TIA Portal)

http://support.automation.siemens.com/WW/view/en/60497002

http://support.automation.siemens.com/WW/view/en/45787660
http://support.automation.siemens.com/WW/view/en/60497002
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